DodgeIntrepid.Net Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
I just bought an '02 police package trep w/ 18K on the odo and I'm having issues w/ the cruise control. I'll be sailing down the road w/ cruise on with no problems and *poof* it magically just turns itself off and wont turn back on. Try it again and again and nothing. Give it 10 or 20 mins and it'll eventually start working again. Any ideas? I am pretty car savvy, but haven't a clue as to the inner workings of cruise control. Any input would be appreciated.

Thanks!

Dre
 

·
Registered
Joined
·
7,101 Posts
Its the cable that goes across the engine, from the Throtle body to the curise control box thing. by your winshield fill tube. Mine was wearing out and eventually broke.

--Gorm
 

·
Registered
Joined
·
3,934 Posts
Also check your brake pedal clearance and free play. If it can move up nd down even a little, it can active the brake light switch which will also turn off the cruise.
 

·
Registered
Joined
·
5,188 Posts
Does the cruise light go off or does it just stop maintaining speed? If the light goes off that would eliminate the possibility of a brake switch problem and probably a bad cable too.
 

·
Registered
Joined
·
1,992 Posts
Brake light switch gets my vote!
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #8 ·
The cruise light stays on, how would I tell if it was the brake light switch? I do notice that there isnt a whole lotta travel on the brake pedal b4 the light comes on, but how do I diagnose whether or not thats the problem?
 

·
Registered
Joined
·
3,934 Posts
When you look at the pedal/switch, if you can lift the pedal away from the switch and the switch moves out, or you can very gently move the pedal down against the switch and agaion it moves, then it is possible that the p[edal/switch is out of adjustment
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #11 ·
Ok, I've been having a blonde day (I have brown hair lol). I had forgotten that these cars have the nifty lil code display thingy-ma-jigger. And that I had the service manual thanks oh so much to this board. I have a P0586 and P0582 - Which means:

P0582
Speed Control Vacuum Solenoid
Circuit-
An open or shorted condition detected in speed control
Vacuum solenoid control circuit.

P0586 Speed Control Vent Solenoid Circuit
An open or shorted condition detected in speed control
vent solenoid control circuit.

Ok, so thats great...I know what the car says is wrong...now could someone who knows a heckufalot more about these cars translate this from Intrepid-ese to english?? LOL Thanks!!!
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #12 ·
Ok, after some creative searching, I found a sketch on here of the servo assembly, and a post that mentioned corrosion on the wiring harness. I took the connector off and didnt see any corrosion, but I hit it with some electrical contact cleaner anyway, plugged / unplugged it a few times (its the IT guy in me...if it doesnt work, just unplug it and plug it back up lol). Pulled the - terminal to clear the codes, took it for a spin, and it seems all is well...no problems, no codes...we'll see how it does on my 100 mi road trip tomorrow.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top