DodgeIntrepid.Net Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,312 Posts
Discussion Starter #1
Well, my cars been stalling out when idling, but not all the time. Could this be do to a dirty IAC sticking? I'm going to clean it tomorrow. Also, could this be a sign of a bad cam position sensor? Are they just unbolt and bolt in new one, or is there something special I have to do, thanks guys!
 

·
Registered
Joined
·
424 Posts
if cam is acting up, it should give you a code. other than that I would try to clean the IAC. IT is amazing how much that with fix.
-Taaf-
 

·
Registered
Joined
·
1,037 Posts
If it is very dirty, check the breather hoses from the black plastic piece behind the throttle bodies. If they are cracked, you'll suck in unfiltered air.
 

·
Registered
Joined
·
1,439 Posts
If your IAC is dirty, clean it and replace PCV valve and check PCV system hoses.
 

·
Registered
Joined
·
91 Posts
my hoses look pretty shitty ,there very soft were they conect where is this iac at dudes PCV system hoses.look shitty i mean
 

·
Registered
Joined
·
3,041 Posts
drac1 said:
my hoses look pretty shitty ,there very soft were they conect where is this iac at dudes PCV system hoses.look shitty i mean
IAC is located on your 3.3 L here:


The idle air control (IAC) motor attaches to the bottom of the throttle body on the 3.3L engine
 

·
Registered
Joined
·
1,439 Posts
drac1 said:
my hoses look pretty shitty ,there very soft were they conect where is this iac at dudes PCV system hoses.look shitty i mean
Is your PCV hose sagging and closing itself off at the 90 degree bend where it attatches to the valve cover?
 

·
Registered
Joined
·
91 Posts
ya i cut some away but im going to get a new one when i get my cam sensor.again thanks dudes your a life saver .later dave
 

·
Registered
Joined
·
1,439 Posts
drac1 said:
ya i cut some away but im going to get a new one when i get my cam sensor.again thanks dudes your a life saver .later dave
In the nearly 12 years I owned the '94 3.3 I must have replaced the saggy ass PCV hose at least 4 times. I am not a big fan of any kind of butcher work but I had to do something. So I spent a whopping 59 cents on an ordinary shelving bracket and sawed off one of the legs . filed it smooth,and wrapped the cut end with a piece of the old hose. The other end already had a nice handy hole in it for mounting. On the drivers side where the coil pack is, there is a bracket that supports one of the power steering hoses. That bracket is attatched with only one bolt to the top of the coil pack bracket. I used that bolt to hold my butcher work in place with the sawed off end under my newest and never to be replaced again PCV hose.
 

·
Registered
Joined
·
1,312 Posts
Discussion Starter #12
Thanks for the info guys.
 

·
Registered
Joined
·
1,312 Posts
Discussion Starter #13
That thing was dirty, cleaned it, seemed to fix my idle.
 

·
Registered
Joined
·
1,037 Posts
Glad to hear it.
 

·
Registered
Joined
·
219 Posts
i want a diagram for the 2.7 on this plzzzzzzzzzzzzzzzzzzzzzzzzzz ive been looking all over and cant find it!!! ; ( **crys**
 

·
Registered
Joined
·
33 Posts
Does a bad or dirty IAC throw codes? Cause I am still fighting with my car stalling on me while Idle. I too am going to change my cam sensor sometime next week, but I'm guessing that I should get the IAC checked out as well correct? And is it better 2 change the IAC or clean it out. This is NOT a problem I want 2 have again. I had a car show 2 do last week and had 2 drop out cause my car kept stalling
 

·
Registered
Joined
·
1,806 Posts
IAC will not throw codes that i know of. I would just clean it, i havn't herd of an IAC going bad before but i'm sure it's happened. They are extreamly easy to clean, just unplug the wire that is connected to it, pull the two bolts and pull it out, spray some carb. cleaner on it wipe it off, and get all the black carbon off it, and then reinstall it, plug your wire back in. Start your car and see if it's fixed. Should I replace my PVC valve, I dont know if it's been changed or not.. My car run perfect so i dont think i need to other than when it's cold it has died on me once wile idleing but thats cause i had my idle adjusted to low..

Clayton
 
1 - 17 of 17 Posts
Top