DodgeIntrepid.Net Forums banner

201 - 220 of 276 Posts

·
Woober Goobers!
Joined
·
50,043 Posts
It appears the Echlin module was a common upgrade for early Mopars to dump the Lean Burn Crapola. Seems people used it on other brands also as it was a good replacement for the original Mopar parts at the time.
 
  • Like
Reactions: Intrep_ED

·
Registered
Joined
·
19,563 Posts
Discussion Starter #203
Wow.. really Charlene?

So........ I'm off today and planned on working on the car, and trying to figure out why she wouldn't start, after she was running fine the day before yesterday (Saturday) I was letting her idle in the driveway for a few minutes after replacing the cap and rotor, and she stalled. Tried to restart with no luck... I checked for spark at the #1 spark plug and had nothing (checking the old school way).

So I decided to replace the coil... figuring this car is 37 years old, and I'm most likely having multiple issues... the fuel issue seemed to be resolved, as she's been running great with me driving the car all around town all week. Now it could be something else. The "no spark" condition I observed led me to the coil conclusion, so I installed said new coil and still nothing. "Seemed like" I was still not getting any spark. (for the record, a couple weeks ago when I was having issues, I checked for spark and had plenty of spark/arc between the cable and the block when using the old school method))

For good measure, I also replaced the resistor since it was only $5 and they had it in stock when I bought the new coil. Still nothing.. crank crank and crank, but no fire. It was at that point that I gave up for the day and went to bed... taking the Honda to work Sunday for my double shift.

-Monday a.m.-

This morning I get in and turn the key and she starts right up! Again... like nothing ever happened. WTF Charlene!

So is heat playing a role here in my intermittent problem? Maybe the control unit (the TP51 ECU) is getting hot and malfunctioning? It can't be the coil because it did the same thing with a brand new one. I don't see how the ECU could be getting all that "hot" way over there on the fender. Perhaps this weird changing in weather/temp lately is playing a role? (it's been real warm during the days up into the 80's (F) then dropping to the 40's (F) at night)

I'll follow Dan's advise and go buy a spark test light to eliminate the "no spark" from being a figment of my imagination for the next time she decides to not "put out" lol

So let me make a little list here of the things I've done/fixed/replaced on Charlene during the first two months of our relationship:

Purchased: 2/15/17 (the day after Valentine's Day - I'll always remember this day because it was the day the GF pointed out that instead of buying her something nice for V-day, I went and bought myself a Córdoba.......

(...and thus began the curse)


2/16/17 ~ 3/1/17

• New oil and filter - I plan on running conventional in her, but for the time being, I had a 5Qt jug of Mobil1 already in the garage, so I went with that for now. Bought a new Mobil1 filter.

• Replaced various bulbs

3/6/17

• Transmission rebuilt 2 yr/24k mile warranty

3/1/17 - 4/10/17

• Fuel Filter

• New Battery (the car had the wrong battery in it. Bought the correct one and upgraded to HD version)

• Spark plugs (Champion copper plus)

• Wires

• Distributor cap & rotor

• Fixed speedometer (cable was loose behind cluster)

• New AC/Delco idler arm (tie rod ends are next, then wheel bearings, ball joints etc - all the fun stuff I know how to do!)

• Started using Non-ethanol fuel.


I guess the strategy here is to continue throwing parts at her. Next on the list is the ECU itself from that NAPA link (thanks guys!) and then the pickup coil in the distro.
 

·
Woober Goobers!
Joined
·
50,043 Posts
Whizzzz....Bzzzzttttt....YOW!
 
  • Like
Reactions: Intrep_ED

·
Registered
Joined
·
19,563 Posts
Discussion Starter #207
It was the ECU! I called the closest Napa, they had the TP51 in stock... went and picked it up, came back, installed it, and Charlene comes back to life! So sure, that I immediately took off for a drive in her...
 

·
I hit **** with sticks!
Joined
·
37,539 Posts
It was the ECU! I called the closest Napa, they had the TP51 in stock... went and picked it up, came back, installed it, and Charlene comes back to life! So sure, that I immediately took off for a drive in her...
Woot!! Now for the test drive...............:riptires:
 

·
Woober Goobers!
Joined
·
50,043 Posts
Will Ed-Doba return with a running Charlene or........................................................?
 
  • Like
Reactions: Intrep_ED

·
Woober Goobers!
Joined
·
50,043 Posts
Ed-Doba....what are those two boxes mounted to the firewall on the passenger side? Upper left of the picture. One is Red and the other? I see the Echlin TP 51 is mounted to the passenger fender up front in the lower left of the picture.

Curious on what the other two are?
 
  • Like
Reactions: Intrep_ED

·
Woober Goobers!
Joined
·
50,043 Posts
Think it was the Echlin for the intermittent crapping out? Guess time will tell. How much did the Echlin cost you?
 
  • Like
Reactions: Intrep_ED

·
Registered
Joined
·
19,563 Posts
Discussion Starter #216 (Edited)
Think it was the Echlin for the intermittent crapping out? Guess time will tell. How much did the Echlin cost you?
I got the Napa house brand equiv. "PROformer" TP51SB for $23.79 plus tax. Was the only one they had in stock, and it was cheap enough and easy enough to install, just to see if it clears up my no start issue.
 

·
Woober Goobers!
Joined
·
50,043 Posts
PROforming like a Sir!
 

·
Registered
Joined
·
13,702 Posts
Despite all the migraine headaches Charlene has caused you aside from transmission and battery mostly everthing else has been in the $20-30 range. A lot easier than forking out 300-400 and still having the same problem.

I'd love to get my hands on a nice 84-86 5th Ave with low mileage.
 

·
Woober Goobers!
Joined
·
50,043 Posts
Despite all the migraine headaches Charlene has caused you aside from transmission and battery mostly everthing else has been in the $20-30 range. A lot easier than forking out 300-400 and still having the same problem.

I'd love to get my hands on a nice 84-86 5th Ave with low mileage.
One of these Hank?

 
  • Like
Reactions: Intrep_ED

·
Woober Goobers!
Joined
·
50,043 Posts
Looks like a "Gussied" up Ed-Doba!
 
  • Like
Reactions: Intrep_ED
201 - 220 of 276 Posts
Top