DodgeIntrepid.Net Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
98 intrepid ES, engine would start for about 30 seconds, then stall. This would go on for 4 starts each time running for about 30 seconds, then stall. On the fifth attempt there was no start function (turn key to start position and nothing, no click, no sound no nothing). No prior conditions leading up to this. Tried to retrieve codes with tester, no codes were stored. After about 30 minutes of checking wiring, battery voltage, etc. it started. I decided to drive the car and see what happened, and yes something happened. I lost tachometer, speedometer and temp. I decided to have the PCM check out. It was bad and repaired and installed. Engine runs great, BUT the check engine light comes on after about 30 seconds of run time, also the red LED light on dash comes on about 30 seconds after the check engine light comes on. I also have no manual climate control functions or rear defroster. Otherwise the car runs great. I'm thinking the BCM now as I believe it controls some of my lost functions. Any ideas...
 

·
Registered
Joined
·
3,934 Posts
Possible mismatch of Engine controller and BCM from different years. Also engine control may be "looking" for sentry key which could be why it only runs a short time then quits - If you didn't have one before, or it doesn't match your current key. I'd be inclined to look there first if you haven't already.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for the input. I have new data... After having my PCM remanufactured (I send them mine and they tested and repaired as required and sent back), the car runs great with the exception of the following: the check engine light comes on after about 30 seconds of run time, also the red LED light on dash comes on about 30 seconds after the check engine light comes on. I also have no manual climate control functions or rear defroster, also no tachometer, speedometer and temp gauge. Two days of driving I now have climate control functions and rear defroster but no tachometer, speedometer or temp gauge. Car otherwise running great.
Any ideas???
 

·
Registered
Joined
·
462 Posts
I am not sure on the year of the vehicle, but it sounds like you PCM is still bad. The PCM controls everything that you don't have. Is the CEL still coming on?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Thanks for the input. Year is 98 ES. CEL is what?? I have read that I need to have my VIN# and mileage inputed into the new PCM. Do you know this to be true??
 

·
Registered
Joined
·
462 Posts
bkanders said:
Thanks for the input. Year is 98 ES. CEL is what?? I have read that I need to have my VIN# and mileage inputed into the new PCM. Do you know this to be true??
CEL=Check Engine Light.

Yes you need the VIN and mileage put into the PCM. The mileage is just SRI mileage, it is not that important.
SRI=Service Recommended Increments
If the VIn is not programmed into the PCM, the light should still be coming on.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7 (Edited)
Thanks for the input, the CEL is still comming on about 30 seconds after start up along the the red LED on the dash (the light that flashes when the alarm is set). You think the VIN# issue could be the problem?
 

·
Registered
Joined
·
462 Posts
bkanders said:
Thanks for the input, the CEL is still comming on about 30 seconds after start up along the the red LED on the dash (the light that flashes when the alarm is set). You think the VIN# issue could be the problem?
The VIN not being programmed will cause the light to come on. 30 seconds is about as long as it takes for the computers to know they are not getting the VIN message.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Thanks for the input. Programming in the VIN# to the PCM, is this a dealer only item or can tooling be purchased to do this?? Any idea why the red LED light on the dash is comming on?
 

·
Registered
Joined
·
462 Posts
bkanders said:
Thanks for the input. Programming in the VIN# to the PCM, is this a dealer only item or can tooling be purchased to do this?? Any idea why the red LED light on the dash is comming on?
It could be the same thing. Program the VIN and see if the issue is fixed. The tool to write to the computer will cost more then a visit to any dealer. Any shop that has a scan tool with writting ability can do it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
New update, just today on the way home from work my tachometer, speedometer and temp gauge works intermittently (all three come on for a few minutes then all go to zero). CEL always stays on, but the red LED on the dash will turn off when the tach, speed and temp gauge comes on. Also, I can not enter the onboard computer ( key on/off three times thing) also, no codes are being stored. Any ideas??
 
1 - 11 of 11 Posts
Top