DodgeIntrepid.Net Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
Today, it was rainning heavily in Victoria. And then I experienced the most difficult problems with my Eagle Vision since I have bought it. THE ENGINE OVERHEAT!!! Actually, I noticed that the temperature of engine is slight higher when it was rainny before. But, today, the thermostat showed the needle very near the H red zone. And then, the engine has "wu~~" sound. I was forced to stop over and wait 3-5 minutes. And then I restarted the car, at first the needle was still near the red zone....all a sudden, the needle go back to the middle. What is happening actually? Does anyone know tell me??

Why is my Eagle Vision overheat during rainny day.

And then, I went to Walmart to have some shopping, then, I went back to car and restarted and started my trip to SAVE ON FOOD. Everything was fine at the begining, however, things happened again in over 5 minutes drive.

After I have done shopping from Save On Food, I need to drive around 10 minutes back to home. This time, the engine was so good and the temperature needle kept below middle.

So, what is going on?

Thanks.
 

·
Registered
Joined
·
1,880 Posts
I think it might be your thermostat. It is really easy to replace and you can get the part for about 15 bucks. Search around the forums, you should be able to find out how.

If its not your thermostat, you might have the problem of a bad water pump. But don't jump to that conclusion yet.

Check for basic things, make sure your cap to the coolant bottle is screwed on tightly. If that isn't the case, make sure you have enough coolant? Is your coolant mixed 50% water 50% coolant? Check all of these things...and make sure you have enough coolant in after the overheat. Good luck.

Duncan
 

·
Registered
Joined
·
1,825 Posts
I would guess the thermostat as well. Its cheap and easy to replace. However, it could also be the water pump. Replace the thermostat and if it overheats again, replace the water pump. Its fairly easy to do on a 3.3 as compared to the 3.5
 

·
Registered
Joined
·
175 Posts
Discussion Starter #4
However, when the needle pointed to the red zone, the whole car has a very very uncomfortable "wu~~~" sound. That's why I am guessing it is not a thermostat problem.
 

·
Registered
Joined
·
638 Posts
I think it's the thermostat as well. If it's stuck closed then you won't have sufficient coolant flow. How's your coolant level?
 

·
Registered
Joined
·
175 Posts
Discussion Starter #6
I have just checked the level of coolant. It is totally empty. Then, I asked my friend to give me a drive to the nearest Esso and buy some premixed coolant.

Once I got back, I filled in all the coolant. And started my car and had a test run. The trip to my destination is very good, the needle shows below middle. Once I arrived the destination, I shut down the engine and take a walk (still rainning).

When I tried to have my return drive back home, the tempeature rose up again and one marker above the middle.

So, I was so frustrated. Once I have parked my car in the parking lot, I opened the hood without the hood to see what was happening under the hood without the engine shut down. Then, I shut down the engine, there was steam coming up from the radiator (passenger side). I was so scared at that time. Can anyone tell me what is going on? When I restarted the engine, the steam disappeared immediately. Then I shut down the engine, the steam appeared again.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #7 (Edited)
Here is some more information for you guys to think of....

Sometimes, when I stop at a light, my gauage will drop back to 1/2 or even below 1/2. Sometimes, when I was driving, the temp guage will drop from 6/8 back to 1/2.

So, is it because the thermostat is out?
If so, where is the thermostat? Can I locate and replace it?

For the steam thing, is that because my thermostat is closed while I was driving, so the coolant cannot arrive the radiator? And when I shut down the engine, the thermostat open and let the coolant enter radiator? That why there is steam immediately?

I know nothing about mechanic, correct me if I am wrong.
 

·
Registered
Joined
·
4,288 Posts
it sounds like your losing pressure through your coolant cap but....it happening only when it rains points to the temp sensor getting wet. could be both....to hard to tell without being there.

anyone else with ideas?
 

·
Registered
Joined
·
175 Posts
Discussion Starter #9
I have just read some articles on DI.net.

One thing that I want to point out is the heater doesn't blow hot air although i have set it to full blast. Then, someone replied earlier articles that it may related to thermostat. The coolant is not circulating.

So, I think my ESi has a thermostat problem. Where can I buy the thermostat? Can I buy it from Canadian Tires?
 

·
Registered
Joined
·
1,880 Posts
Like I said before, its probably your thermostat. Keep in mind:

When you do stop and go driving, your car will run hotter because there isn't as much air being pushed into the radiator...Stop and go...and idling are hotter. Expressway driving is much cooler, which you may have noticed by now, because so much air is being pushed into there.

All of these problems you're talking about could very well be the thermostat. Never underestimate the problems a bad thermostat can cause.

Duncan
 

·
Registered
Joined
·
175 Posts
Discussion Starter #12
thanks for all you guys.

My car is now having a thermostat change. Let see if the problem is solved.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #13
I have replaced the thermostat and the problem is solved.
Thanks for the helps.
 

·
Registered
Joined
·
1,825 Posts
Glad to see that it worked... and that it wasnt too expensive for you either as it wasnt any other problem.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #16
Oh yeah, you're right.
My Vision is running very well now.
Thanks a lot.
 
1 - 16 of 16 Posts
Top