DodgeIntrepid.Net Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Hey all,

New kid on the block here. Have a queston about the EVIC system. I want to install one in my trep, 2001 ES. I've been reading the threads but still a little confused. Does anyone know if it will work on an '01 and if wire harness is already there? Any opinions on where I can find one, besides the dealer? Do I need to get one from a 300m? What years had the PSI feature? What exactly do I need to get as far as Console, module, wiring, etc.?

I'm gettin' dizzy! :confused:

Thanks!
 

·
Registered
Joined
·
11,278 Posts
you should already have all the wiring in your existing OTIS, just remove it and plug in the EVIC, the tire PSI is a feature dependent on the wheel sensors and the EVIC, not anything within the car

yes, you do need to get one from a 300M simply because those were the only cars to use them, LHS's, Concordes and Intrepids never came with EVICs
 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
Thanks Joe,

I guess I forgot one detail. It seems that my ES is one of the few that didn't come w/an OTIS either!:cry:
 

·
Registered
Joined
·
5,763 Posts
If you find an EVIC just ask if you can hav the harness that goes with it. I just made up an OTIS/EVIC harness for someone that is plug and play. Basicly I just added a female connector to plug your courtesy lights into, then all you do is run the new harness along side the old one, unplug the old one and plug the new one in. PRESTO your done.
Don't forget you have to cut a bigger hole in the headliner to make the OTIS/EVIC fit. I'm not getting notification of replys to posts I've made so if you have any other questions, PM me.
 

·
Registered
Joined
·
45 Posts
EVIC+PSI in 99 LHS

I just installed an EVIC in my 99 LHS and the PSI sensors are WONDERFUL. However, many of the menu functions (Horn on Lock, all doors unlock, etc.) arent working, I get My MPG, compas , Temp Etc. My LHS came with all the bells and whistles that were offered in 99 and I assumed that the OTIS and EVIC were plug and play. Coud I be mistaken? is there something that might be missing from my 99 harness that would make this happen?

Thanks for any info...
 

·
Registered
Joined
·
1,495 Posts
Re: EVIC+PSI in 99 LHS

winthropgrad said:
I just installed an EVIC in my 99 LHS and the PSI sensors are WONDERFUL. However, many of the menu functions (Horn on Lock, all doors unlock, etc.) arent working, I get My MPG, compas , Temp Etc. My LHS came with all the bells and whistles that were offered in 99 and I assumed that the OTIS and EVIC were plug and play. Coud I be mistaken? is there something that might be missing from my 99 harness that would make this happen?

Thanks for any info...
Here's a thread containing everything you'll ever need to know about OTIS or EVIC
 

·
Registered
Joined
·
7,101 Posts
JoeKD said:
you should already have all the wiring in your existing OTIS, just remove it and plug in the EVIC, the tire PSI is a feature dependent on the wheel sensors and the EVIC, not anything within the car

yes, you do need to get one from a 300M simply because those were the only cars to use them, LHS's, Concordes and Intrepids never came with EVICs
Now wait...Ive seen a wrecked LHS with an EVIC. Are you sure they didnt come with them?

--Gorm
 

·
Registered
Joined
·
8,099 Posts
gormo66 said:
Now wait...Ive seen a wrecked LHS with an EVIC. Are you sure they didnt come with them?
i don't know wether or not they came with them...but just because you saw it doesn't mean it came from factory.

just think how many intrepids from this site will eventually go to junk yards with EVIC's :p
 

·
Registered
Joined
·
45 Posts
Re: Re: EVIC+PSI in 99 LHS

RapidTransit said:
That thread is the one that convinced me to search out an EVIC +PSI for my LHS. I have it installed and the PSI sensors, avg mpg, DTE trip meter service interval etc work. When i use the menu to, for instance, change the settings to make the horn beep when locking the car, the horn doesn't beep. Same issue with setting the 'all doors unlock' when using the remote, headlamp delay, and all of the other 'menu' items. They just won't change. Any ideas if the BCM is different. I am not sure what model/year the evic was (Intrepid99.....??). maybe that is the issue.

The PSI peace of mind was well worth it, even if i dont get the menu items to 'reprogram.'
 

·
Registered
Joined
·
45 Posts
YB Normyl said:
Most of those features only work on 2000 or newer because of the BCM difference.
What would be involved in replacing 99 LHS BCM w/ 2000 300m or later BCM?
 
1 - 14 of 14 Posts
Top