DodgeIntrepid.Net Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
allright heres the deal. i have a 94 intrepid es with a 3.3 in it. probably about a year ago i had a flowmaster put on with some 2 and a 1/4 inch pipe from the cat back. right after that i finished rebuilding the 95 3.3 motor that i picked up and put it in. the old engine smoked on acceleration most likely the valve stem seals. the 95 motor was worked by a reputable machine shop before assembly. about 7 months after the exhaust went on the cat went out on it. i took it to meineke and they put a new one on for $256.(i wish i could weld) about six months later the main cat goes out yet again. so i haul it up to meineke and tell em that its bad. i was wondering if the precats were out and was causing the main cat to go out, so i asked them to check those out. they said that it was fine and the car seemed fine. they told me that the cat was probably defective. they also do not warranty the cats at the stores, you have to pay for another cat and install(another $256)and the warranty is between you and the manufacturer. i did not get a refund from the manufacturer because they said that the cat did not go out becasue it was defective it was somthing else. now six months later its gone out again. i took it up there to give em one more chance and as soon as they got it in there the tech came over and showed me that the precats were both really clogged and thats why the cat went out. so i am replacing them myself and taking it to another shop. anyway my problem is that meineke is saying that the cats are going out because they engines messed up somewhere. the tech deosnt see where or how and neither do i. the engine has now 10,000 miles on it as well as new plugs and wires and runs great. part of this thread was just to vent about meineke but my question is could it be the engine? is it possible that the engine isnt running right because its a 95 motor in a 94 car? any advice would be appreciated.
 
1 - 1 of 1 Posts
Top