DodgeIntrepid.Net Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Ok, First post here, but I do have a question that someone may be able to help me with regarding the power steering pump...

Just bought my step-son a 2000 Intrepid. Bare bones kinda car with the 2.7L V-6.

The power steering pump was bad so I was changing it out (all of $56 at Auto-zone after core return :bigok: ) but noticed that the pressure tube is leaking badly (the tube from the pump itself to the hose leading up to the rack).

So I goes to my local stealership and order a new one. It comes in and it isn't the right piece in that the one I have has two NPT threads on either end and the one the stealership has is NPT on the pump end and quick-connect on the other.

Now here's my question...could it be possible that some Mitsubishi parts made it into the 2.7L builds? I know that some of the Gen-I Intrepids were of the Mitsubishi persuasion in that the engines were not Chryslers doing...therefore it might help me to get the stealership to cross reference Mitsu parts to see if I can get the replacement I need? I am trying to find this part as the stealership's microfiche doesn't show the part I have as being the one for the vehicle...just the quick-connect.

I know my Y2K Intrepid is Gen-II, but sometimes left over parts from the previous generations make it into early builds of the next...not sure where the Gen change occured...

Thanks
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Give the dealer your VIN and then they will be able to find the parts based on the systems installed in your particular car.
That might work if the part was a Chrysler specific part...I'll certainly give it a try, but the guy showed me the Fiche that has the parts in question, and it clearly shows the quick-connect.

It could be that the pump and rack was already replaced (or the hose to it) by an independent and they used something that was available to them that was not OEM...

Thanks for the inputs, and more suggestions are certainly appreciated.
 

·
I hit **** with sticks!
Joined
·
37,841 Posts
That might work if the part was a Chrysler specific part...I'll certainly give it a try, but the guy showed me the Fiche that has the parts in question, and it clearly shows the quick-connect.

It could be that the pump and rack was already replaced (or the hose to it) by an independent and they used something that was available to them that was not OEM...

Thanks for the inputs, and more suggestions are certainly appreciated.
It is a quick connect. The actual quick connect piece is just a nut that screws into the power steering pressure hose from the steel tube= they were made that way so for speed in assembly at the factory, and will only "quick connect" once. The nut has to be replaced after that, and the old one cannot be removed from the tube without breaking it.

They are all Chrysler parts, there was no Mistubishi involvement with these engines.

You need part #5018347 to go along with the power steering tube you bought.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Thanks LOADS 32Intrepid :fun_08::beerchug::fun_08: that was the exact part (it did have an AA after the part number, though).

Even the parts guy was appreciative for the info...he said he learned something new and would file that little nugget away for future reference.
 

·
I hit **** with sticks!
Joined
·
37,841 Posts
Thanks LOADS 32Intrepid :fun_08::beerchug::fun_08: that was the exact part (it did have an AA after the part number, though).

Even the parts guy was appreciative for the info...he said he learned something new and would file that little nugget away for future reference.
No problem. Were they able to get it for you quickly? Those were on back order for a while.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
The parts guy said it'd be a couple of days...That was Monday, so I am hoping it'll be in by the end of the week so (weather permitting) I can button up the repairs and get my step son on the road...:smilie_sc:smilie_sc:smilie_sc :biglaugh:
 

·
Registered
Joined
·
277 Posts
The parts guy said it'd be a couple of days...That was Monday, so I am hoping it'll be in by the end of the week so (weather permitting) I can button up the repairs and get my step son on the road...:smilie_sc:smilie_sc:smilie_sc :biglaugh:
Lucky kid! Plenty of room to haul friends and lots of power. :biggrin:
 

·
Registered
Joined
·
715 Posts
do read up on the 2.7 threads. preventative maintenance is the key especially if you don't know what has or has not been done. good luck with the trep!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
do read up on the 2.7 threads. preventative maintenance is the key especially if you don't know what has or has not been done. good luck with the trep!!
I am already planning on changing out the antifreeze, as well as changing the oil, switching it to Mobile 1...great stuff...I run it in ALL my vehicles (well not my Motorcycle since they switched it to the fuel saving version which doesn't jive well with a wet clutch). I had a '96 Jeep Grand Cherokee with the I-6 that I ran for 238,000 miles that didn't burn any oil that had only Mobile 1.

I'm also going to check the plugs and if they need change out, it'll be done.

I'll check out the threads for anything else.

Thanks all for the tips.
 
1 - 11 of 11 Posts
Top