DodgeIntrepid.Net Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
589 Posts
Discussion Starter #1
Grrr Im pissed as HELL. Ive had the car back for about 2 going on 3 weeks now from when I had it braught in to get the wiring replaced for the cooling fans and everything damaged by my overheating fixed. Well, now the car is stalling out, lagging with its shifting (like when you accelerate the car downshifts to speed up, but when you lay back off the gas it just hangs in that gear for a little bit before shifting back up to the cruising gear) and also started out as a loud ticking which is now a giganticly loud clunking along with engine shaking. Gah... cars going back into the shop before it gets anyworse considering I have lost alot of power going up hills and what not. Any ideas what you guys think, me, my dads, and my friends have determined it sounds like and acts like its either A. Cam Shaft lobes are worn really bad suddenly B. Timing Belt is about to kick it. C. Transaxel is acting up for some odd reason.
 

·
Registered
Joined
·
175 Posts
Hmmm, 2.7L I notice........ I hate to speculate, but based on all I have seen on the board about the problems with thise engines....... My condolences on your iminent loss.
 

·
Registered
Joined
·
589 Posts
Discussion Starter #4
its still running which is what im happy about, but the power loss is gigantic. I have a tow truck coming to scoop the car up and bring it to the mechanic again... and I was looking at the maintence records we keep in the car... it was oil changed with synthetic every 2k miles by my mom, and the transmission fluid was changed every 30k that is untill the car was given to my sister originally because she blew the transmission in her other car by not properly keeping up with engine maintence which is didnt keep up with in this intrepid either... which thank god wasnt long then it was passed to me and ive been trying to keep up with the maintence... though as you can see im starting to see some bad effects... seems like getting a new car is sounding like a good idea soon.
 

·
Registered
Joined
·
31 Posts
The same thing happened to mine stop driving the car the one of the pistons blew that were you getting that ticking and the loss of power witch I also got after I got my car back ended up being something in the tranny. Everything you discribed happened to me.
 

·
Banned
Joined
·
4,553 Posts
DoDgEsPeEd87 said:
The same thing happened to mine stop driving the car the one of the pistons blew that were you getting that ticking and the loss of power witch I also got after I got my car back ended up being something in the tranny. Everything you discribed happened to me.
That couldn't have had anything to do with the "puddle" you drove through, right?! :rolleyes: ...completely different situation, I'm sure....
 

·
Registered
Joined
·
589 Posts
Discussion Starter #7
DoDgEsPeEd87 said:
The same thing happened to mine stop driving the car the one of the pistons blew that were you getting that ticking and the loss of power witch I also got after I got my car back ended up being something in the tranny. Everything you discribed happened to me.
did your check engine light turn on? cause mine hasnt yet... and you can visually see the engine rocking back and forward in the bay as it knocks back and forward... and it originally started only making the sounds at high RPMs but now is even at idle... plus it idles erracticly.
 

·
Registered
Joined
·
9,831 Posts
Trytic said:
and it originally started only making the sounds at high RPMs.
Have you been racing?
 

·
Registered
Joined
·
589 Posts
Discussion Starter #9
what i call high rpms is above shift point... like 4k-5k and thats usually accelorating to a call or something.i dont race usually... been on too many car accidents
 

·
Registered
Joined
·
1,909 Posts
I"ll buy your overlay if you're going to get a new car :) Good luck with the trep tho.


sisters...pfft
 
1 - 10 of 10 Posts
Top