DodgeIntrepid.Net Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I too blew my engine, yes a 2.7...I was on vacation and my crank disintegrated three hundred miles from home...had to stick it with some small town mechanic who charged me 4,700.00 !!!!! ended up with a new rebuilt...apparently these engines are very hard to find (probably because they suck!!! )as such I paid almost 3,400 for the engine. Stupid mechanic had my car for a month! Apparently I had the same problem everyone with this engine seems to have...gunk...lots of it..When he put the engine in I think he wired incorrectly, he blew the main computer and at least two sensors...I finally picked up the car last week...only to find that I also had a bad ignition coil...I replaced that but now have another problem...when I start the car in the AM it sounds horrible (possible muffler hole?) in addition it bucks really bad, feels like Im out of gas...I limp along for a few minutes and the problem dissipates...at first I thought it might be another ignition coil, but now someone told me it might be the coolant temp sensor? not telling the computer to feed more gas at colder temps?. In anycase I,m ready to stop payment on the credit card to this mechanic....he quite obviously, and painfully didnt know what he was doing....can anyone offer any feedback on my current problem? any help would be appreciated...I'd hate to have to put it back in the shop, and Im sure as hell not driving the three hundred miles to get back to this dolt! but Im not sure what else to do

Thanks,

mike
 

·
Registered
Joined
·
2,576 Posts
I would stop payment right away. Sounds like he didn't do the job right. Look in the how to section of the boards on how to pull codes. That will help you find out if you have any censors that are out.

You might have a rough idle due to bad plugs also.
 
1 - 2 of 2 Posts
Top