DodgeIntrepid.Net Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
for some reason, the heat is always on, blowing full blast through the defrost position. It has the automatic stuff in it, with the thermostat and everything.

Sometimes they work, but rarely. Its not that big a deal cuz its winter, but its getting warmer now.

So i'm thinking bad ground? I dunno how the heat works, as i am a GM man. is it purely electric, or vacume?

This is my gf's car btw

Thanks again

Dan
 

·
Registered
Joined
·
125 Posts
Climate Control Fix

Found design flaw last nite while fixin mine.replacing the unit prob wont work. Take the unit out and remove back cover(phillips Head screwdriver).you will find two circuit boards connected by several pins.THESE PINS are the loose connection! You COULD attempt to solder them-I just applied dieelectric (conductive) grease to them and reassembled the unit. good luck

UPDATE:03/24-Started doin it again...gonna try soldering them and I'll let ya know (if I can remember where my soldering iron is...)

UPDATE:08/08- Now it's F%$#*@... After fixin it 5 times it did it again and I started 'tapping' it so hard I broke the casing, then found a guy on epay that fixes the 'cold solder joints' that make these units fail... $60 with exchange IF ya still have a decent one to swap... looks like I'll be paying $200 or fixing my own IF I can find a wiring diagram (and that capacitor that came flyin out when I hit it a LITTLE too hard)...
 
1 - 2 of 2 Posts
Top