DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
The lights that light up the instrament cluster on my 99 concorde only work about 5% of the time. So I took it to a dealer and they said that I needed a new wiring harness and a new instrament cluster which with labor was going to cost around $800 wondering if anyone else has had this problem and what they did.
 

·
Registered
Joined
·
655 Posts
ya i see they are doing the only thing they do to ppl.... :monkeypis everyone in the bum....new wiring harness...new cluster....

i think chances of both being bad for some odd ass reason are so slim that i never heard of such a problem....my guess they will use 200$ of it on the problem and #*$(&*^ u over for the remaining 600$....hate that place...with passion :moon2:

but ok back to the problem, you can try getting a diff cluster, at most 50$ (but im sure someone on DI could sell u one for 30) on junky...if that doesnt work...my next best guess would be the light switch (that's assuming the wires and the two plugs in the back of that cluster are fine)
 

·
Registered
Joined
·
655 Posts
ahh forgot to add

they probably dont even know what the problem is and are trying to get u into buying new parts and paying ridiculous amount of money in hopes that it would fix the problem.
 

·
Registered
Joined
·
603 Posts
if it has the indigo, make sure the power box for that hasnt vibrated loose making the connections connect every once in awhile. I have a cluster back with indigo that I can send to you also, the guages are off because I was trying something, but the back is still good so all you would have to do is but your face on and plug the indigo in and off you are. It doesnt have autostick however. PM if interested.
 
1 - 4 of 4 Posts
Top