DodgeIntrepid.Net Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
884 Posts
Discussion Starter #1
I have had my Clarion TV in the trep for about 2 years now and i just started to blow fuses.I'm running the power wire to the Lighter/Ign/batt fuse block. and i have the ground to a bolt in the metal dash frame inside the fuse panel. I don't know what this could be. Anyone have any ideas?
 

·
Registered
Joined
·
8,625 Posts
This is going to sound stupid but have you checked the in line fuse on your TV? or checked to make sure a wire has not been exposed behind the dash? Also when I had my TV I had my ground to the metal plate right below the two din slots. just a couple of things to think about hope you find the problem.
 

·
Registered
Joined
·
8,649 Posts
What fuses are you blowing, the inline ones on the TVs or the main circuit fuse in the OEM fuse block? The only reason for a fuse to blow is too much current draw. I would start unplugging things and make sure nothing is wrong with the equipment. If fuses continue to blow then you're probably looking for an exposed wire somewhere...
 

·
Registered
Joined
·
884 Posts
Discussion Starter #4
the OEM fuse block is where it's blowing. I'll have to check the inline fuse tonight.
 

·
Registered
Joined
·
8,649 Posts
Well, if the OEM fuse block fuses are blowing then the problem lies between the inline fuses and the OEM fuse block...
 

·
Registered
Joined
·
884 Posts
Discussion Starter #6
So I checked into the wire problem and come to find out i had some exposed bare wire in the dash. it was it. it's back to normal now. thanks for everyones help.
 
1 - 6 of 6 Posts
Top