DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My 95 ES was running sweet up until I driven it one morning to work at hi speed and came off expressway and immediately hit a bunch of pot holes and broken ice. The car got rattled and then immediately began to act funny. When I would attempt to accelerate and she would reach about 2,000rpm the tach / engine would suddenly drop. If I attempt to push thru-it, she would pick up speed but feel like she wanted to die. However, at idle she would be fairly stable, with an occasional "miss" (post pot hole incident mind you), but seem to idle rather normally. Another odd symptom is that as I try to push thru-it the cruise control light intermittently flashes on, and off when I back off the accelerator. One mechanic said "we need to start with a tune-up" - I took it home and did the tune up (plugs and wires). Still has the problem. Another mechanic says it is in a "open-loop state" (running rich and causing some back-firing) and won't go closed loop, but doesn't throw any computer codes or check engine light. He recommends "we start with a PCM replacement". I feel uneasy about spending the $600 on a computer when he cannot even be sure it will solve the problem - and besides, there aren't any codes or chk engin light. ANY IDEAS? ANYONE EVER EXPERIENCE SUCH SYMPTOMS?
I suggested they check out the O2 sensors since my Hyanes manual makes reference to the car remaining in open loop when these go bad.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I read "limp mode" referenced in the earlier postings but I am not sure how it was defined....
 

·
Registered
Joined
·
7,101 Posts
Hey dude,

You might get some more help if you post this in the first gen fourm. Usually members who might know of this type of problem don't ususlly see the problems in this thread.

But welcome anyways! Glad you like the site.

--Gorm
 
1 - 4 of 4 Posts
Top