DodgeIntrepid.Net Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Just finished installing new Mopar front strut assemblies - everything but the springs which seemed fine. I did the job because a mount and bearing were bad on the driver's side. Side note: the side with the broken mount, the strut tower was not put together properly from the factory. The notch was not at 10 o'clock, more like 5:30.

Anyway, neither FSM nor the Haynes said anything about getting the front end aligned, but I've always done that after strut jobs o my other cars. I'll at least get it checked but what should I expect - is alignment necessary?
 

·
Farticcus of Plenticcus
Joined
·
17,030 Posts
Yes, absolutely...
 

·
Registered
Joined
·
36 Posts
Discussion Starter #7
Front toe was way off, everything else was in spec.

Of course the adjusting sleeves on the tie rod ends were rusted beyond recognition, so I had to replace those ...
 

·
Woober Goobers!
Joined
·
51,010 Posts
Did you get the "Good" adjusters or just crappy OEM style replacements? LOL!
 

·
Premium Member
Joined
·
17,323 Posts
Front toe was way off, everything else was in spec...
Good you got it checked. Bad toe is what does a real job on the tires.

...Of course the adjusting sleeves on the tie rod ends were rusted beyond recognition, so I had to replace those ...
Did you get the "Good" adjusters or just crappy OEM style replacements? LOL!
Exactly!! :)
 

·
Registered
Joined
·
36 Posts
Discussion Starter #10
The alignment guy knew all about it - I put on the upgraded adjustors!!!!

:yay::sohappy:
 
1 - 10 of 10 Posts
Top