DodgeIntrepid.Net Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3,041 Posts
Discussion Starter #1
I always had a problem with the wipers skipping had highway speeds around 65+ Mph. So I went a got a set of Bosch Icon wiper blades, and I have tested them up to 95 Mph in the rain. ( just for the test, you shouldn't drive that fast in the rain anyway's). And they where still glued to the windshield. And they are one quiet blade too.



Features:
The ''B'' series features a lower proile and fits passenger side applications where the hood clearance is smaller.
Bracketless Design
Enclosed tension springs
Wind Spoiler Design hugs the windshield
Even pressure across the length of the blade for better vision.


I highly recommend these blades to any 1st Gen owner !
 

·
Registered
Joined
·
54 Posts
I'm heading down that road shortly myself.I was gonna go with Bosch Micro Edge Excel,but just might have to check into these things.As always,thanks for the info,Strongt....
 

·
Registered
Joined
·
3,041 Posts
Discussion Starter #3
justadude said:
I'm heading down that road shortly myself.I was gonna go with Bosch Micro Edge Excel,but just might have to check into these things.As always,thanks for the info,Strongt....
Don't worry about the number's when you go and buy them, just look at the last 2 numbers on the box that's the size. Like 24" and ect. And choose the "B "series for the Pass side, just so the arm sit's more lower to the windshield. But if they don't have the "B", "A's" will work just fine.
 

·
Registered
Joined
·
3,041 Posts
Discussion Starter #6
mass04 said:
where did you get them and how much did they cost?
I got them at Autozone for $ 22 each. But they give me a $15 Gift card for buying them.
 

·
Registered
Joined
·
313 Posts
Just a thought, but if you guys' wipers are skipping that bad, you might try replacing the wiper arm, or at least the spring inside it. It seems to me thats what would hold it against the windshield, not the blade springs. I still have my factory wiper arms and blades, and they work perfectly. I just replace the rubber blade when I need to. Mine came factory with the little spoiler thing on the driver side wiper, which probably helps alot.
 
J

·
Guest
Joined
·
0 Posts
Ya, I had the same problem, it's that damn arm and the spring in it. It is also dirty windshield. I replaced my wiper arm, wiper blade with the new spring arm (junkyard) and also, I cleaned my windshield glass with turpentine and rubbing alcohol.
Then - it stopped skipping.. Matter of fact, I dunno how hard I rubbed it, but rain won't stick to it now either.. lol. Good 4 me. lol.
 
1 - 9 of 9 Posts
Top