DodgeIntrepid.Net Forums banner

1 - 5 of 5 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #1
ok...well this may be a bit long...well i decided to go to this gas station that has REALLY cheap gas...my mother took her car to it and it has done fine...so i took mine..well it ran like usual for about 10 min or so...then it just started shaking really bad...kkeep in mind that my car runs ssoooo smoothly that my mother couldn't tell if the engine was runing one time...well i pretty much know it was the gas that messed it up...but i figured that i would run down the gas to half a tank then fill it up with the highest gas i could...so it would mix in with the shitty gas and kinda dillute it...but it didn't work...my car still shakes ..not as bad but still not what it used to be...do any of you know what the gas could have done to my poor car?
 

·
Registered
Joined
·
2,576 Posts
sounds like an injector might be clogged or something. Try running some STP complete fuel injection system cleaner. Also, depending on how much mileage you have on your car, you may want to consider changing the fuel filter out, and maybe even the spark plugs.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #5
well thats the thing...i put this gas in more than a month ago...so the basd gas should well be out of there by now i would think...i also put octane booster in it as suggested by someone...didn't do much help...also i have platnum spark plugs and just got them check a few weeks ago...they are fine...and its possible they put water in it..it was this little mexican place...not even a mobil or anything name brand
 
1 - 5 of 5 Posts
Top