DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Folks, here is the run down.

I've spend some time reading the forum and can't find anything here that sounds like my problem.

I have replaced the fan assembly,radiator, thermostat and coolant sensor.
Tested the relays-OK
Jumpered relay terminals-Fans will operate
Checked wiring at the relays- power where it should be, grounded where it should be--
Except I have no way of knowing if the PCM is grounding the fan relays
Oddly enough, on initial start of the engine, the fans will run for approximately 10 seconds then quit.

I took the PCM out about a week ago and cleaned the connector?
At first the fans came on and never went off. Then it worked properly for about a week.
Now it overheats. The fans will not come on.

Any ideas what is next.
 

·
Registered
Joined
·
3,041 Posts
My one thought: A/C Pressure Transducer. A bad pressure transducer will make the fans not run. alteast it's easy to fix, just unscrew it out of the a/c line and but in a new one. There is a valve inside that will let the freon leak out when you replace the transducer.

Cost: around $35 at a parts store.

It's one of the many common failure points on these cars.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanx for the idea, soooooooo
Called al the usual, Pep O'Reilly Advance Zone NAPA nobody has it.
Get this......Called the dreaded Dealer...National backorder....for months
Guess I am headed to the boneyard
Strongt.......is there a way to bypass this switch just to see if it is the fix?
If I unplug it, should the fans work, or do I jumper the harness?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Also those folks that said they could order it want $75.00........for a switch.
I guess if it is on backorder, then that is a lesson in supply and demand
 
1 - 4 of 4 Posts
Top