DodgeIntrepid.Net Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2004 Dodge Intrepid 2.7 and I'm getting OBDII Code P0480 and that's all. Both fans will turn on when the A/C is on. With the A/C turned off, no matter how hot the engine is, no fans will not come on at all. I've already replaced the Radiator Fan Relay. Same results.

Could it be the Coolant Temperature Sensor? I wouldn't think I would have bad fans since they do work well on High when the A/C is on.

Any help would be greatly appreciated.
 

·
Premium Member
Joined
·
18,389 Posts
If your temp. gage is working correctly, then the temp. sensor is not the problem. The PCM uses the ouput from that one sensor to control the engine cooling fans *and* to send the info. to the BCM to drive the temp. gage.

Maybe the low speed circuit is faulty, and you're never getting it hot enough for the high speed fan circuit to come on?

The fan controls originate from the PCM, whether the fans are commanded on due to the a.c. being on or due to engine temperature.

Can you read and troubleshoot from schematics? If so, use the schematics from an FSM to trace the fan control signals from the PCM outputs, thru the relays, and to the fan motors. (Make sure you follow the circuit for the 2.7 - not the "Except 2.7" - they are different.)

Check the connectors in the fan assembly - possibly a low speed terminal is loose or corroded, or connector is not fully mated?
 

·
Premium Member
Joined
·
18,389 Posts
Do I need the hi/lo relay and the hi relay!!.
For your fans to operate correctly, yes. Are you having a particular problem with your fan operation that you're trying to fix? Do you have code P0480? What year car and what engine do you have?
 
1 - 4 of 4 Posts
Top