DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My tranny is in limp mode...I reset it to try and clear and it came right back. Codes that I am getting is P0432, but that shouldn't have put the car in limp mode, and P0605, ROM error of some kind. I got the codes, but I can't find what anyone says to DO about this one in particular, and what may have caused it. I had a valve job done 2 months ago, and the car is still under warranty for that, so if this problem is in anyway related, I want to get them to do it. If not, it is a looong drive to that dealer at 30 mph.

Any help?
 

·
I hit **** with sticks!
Joined
·
37,696 Posts
P0605 is a ecm memory error. If your car is a 2002-2004, you will need a new engine ecm. 98-01, a new transmission ecm.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
is there no way to reset it?

Sometimes computers just need a little cntl-alt-del action... is there no way to reset the TCM? its a 2001. The codes are a little confusing. I had the tranny limp mode problem first, took it to AAMCO, and they said it wasn't the transmission mechanics, it was electrical. They wrote 2 codes on the paper, which I assume the retrieved from the TCM? p0432 and p0605. I learned on here how to check for codes and reset the computer. I got a P0700. I changed the input sensor. Reset computer, and code came back. the P0700 was never on the paper from AAMCO. Are the codes from two different places, the TCM and the ECM? Can you help me sort it all out, and what can I do myself vs. having to take it somewhere.
 

·
Registered
Joined
·
1,992 Posts
I believe the P0700 is communication from the TCM(transmission Control Module) indicating a problem has been detected...
If you're at all handy with a wrench,likes others said, buy the two tranny sensors and try it.
I've got 162K on my '00 transmission (two motors) with a moderate abuse level after I put a 3.2 in,and it's holding up well.
 
1 - 4 of 4 Posts
Top