DodgeIntrepid.Net Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey i am new to all this so here it goes....
My sis inlaw has a '99 intrepid w/ 2.7 new battery, have the cuts on my hands to prove it LOL, and nothing. when you try to turn it over it clicks. but you you attach jumper cables to it, it starts. any ideas anything and everything will be helpful.

PS relays are working fine.
 

·
Registered
Joined
·
376 Posts
Have you checked the voltage at the battery itself? Depending upon where you bought it I wouldn't be too sure it was fully charged. Also, it's possible the battery is defective. I got a Die Hard a few years back that had 2 dead cells brand new.

When you jumped it how long did you let it run for?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
yeah i checked the battery cables and terminals did an anti corrosion treatment and also i work at walmart in the Tire and Lube Express and i did a battery, starter, and charging system test on it and all was good. i think it may be the ignition. i hope not though.
 

·
Registered
Joined
·
3,552 Posts
oh, and just a heads up.. He argued the fact that it HAD to be something else.... but when he replaced the starter, it never happened again.
 

·
Banned
Joined
·
4,553 Posts
One other thing to check before doing the starter swap... The jump terminals are notorious for corroding and having a bad connection. Take them both apart, polish them up, and put them back together nice and TIGHT! Very common problem on these vehicles. If that doesn't do the trick, then it's time to take a look at that starter.
 

·
Registered
Joined
·
328 Posts
You took the both nuts of the NEG Terminal post (on the strut tower) and cleaned BOTH cables?
 

·
Registered
Joined
·
1,992 Posts
Yeah. It is possible, and you'll loose knuckle skin...Just remember to take the battery cables loose at the disconnects first. And not have any little kid's ears around you.
 
1 - 16 of 16 Posts
Top