DodgeIntrepid.Net Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
When I use the power locks, the lock motor in the front left door is pretty loud. I can hear it over the horn chirp when locking the doors. I haven't had any actual problems with locking or unlocking the door, however. Should I be concerned with this?
 

·
I hit **** with sticks!
Joined
·
37,838 Posts
Its a bad door lock actuator. The motor is starting to strip internally.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Glad to hear. I've done that before to replace a mirror on my Lumina.

Can someone point out which part is the correct one?

Door Lock Motor - Advance Auto Parts

Oh, and right after I posted this question I started having trouble unlocking that door, about every other time I use the keyless entry. I can see the manual lock switch jiggle and lift a little but it's not unlocking. When it does work, the switch raises maybe half way.
 

·
I hit **** with sticks!
Joined
·
37,838 Posts
Nothing came up for the search on Advance.

Moparpartsamerica is showing the whole latch for about $100, but I am sure the actuator was available separately. Give a call to the dodge dealer on that one.
 

·
Registered
Joined
·
2,660 Posts
Oh, and right after I posted this question I started having trouble unlocking that door, about every other time I use the keyless entry. I can see the manual lock switch jiggle and lift a little but it's not unlocking. When it does work, the switch raises maybe half way.
That is the motor getting worse. It's connected via linkage inside the door and since the motor's failing, your manual locks aren't moving either.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8 (Edited)
@RCE2WIN

The manual lock seems to be working fine.

@DAYTREPPER

Weird. It shows up for me. Here are some part #'s from that search if that will help... #75653, #75611, #DLA122, #DLA128. They *look* to me like different designs and I'm not really sure if that makes any difference which one I go with.
 

·
Registered
Joined
·
2,660 Posts
@RCE2WIN The manual lock seems to be working fine.
Correct, when you manually lock/unlock the door it works fine. You stated in your previous post,
I can see the manual lock switch jiggle and lift a little but it's not unlocking. When it does work, the switch raises maybe half way.
This happens when using the RKE. It's not unlocking b/c the motor is failing and not moving the manual switch completely up.
 
1 - 9 of 9 Posts
Top