DodgeIntrepid.Net Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys, I'm new to registering here but have been surfing this site for about 5 months now looking and reading a lot of things.
I want to kinda keep this a summary, but, here goes:

I bought an 01 Trep ES 2.7 V6 9 months ago, it had been wrecked on front left and put back together all mickey mouse'd by whomever the previous owner took it to.
Anyway, so far this car has proven to be a piece of **** to me all along. It really has, I love Intrepids but damn! haha. Ever heard of Money Pit?

Okay, so...one day I get the clunk noise in rack n pinion, replaced that..power streering for another 3 months. Stops again, drove without power streering for a month.. got a rebuilt power streering pump two days ago, installed it. I even flushed it three times at the rack n pinion to make sure no air was inside the lines, power streering works coming out of driveway, and fails at the end of street, no more power steering. Looked at the pump and it wasn't pumping like it was before, so I took it back today and got it replaced with another pump.
Now the pump pumps like nobody's business! Power steering worked for a few blocks, and now does not work. Came back and flushed the system again, adjusted the belt ant different tensions, everything.

Thing is, 1500 RPM, no power streering, 2500 RPM power steering, 3000RPM+ full blown power streering. Same thing with other rebuilt pump.
I'm starting to think that the rack n pinion has been damaged from driving it for a month or so without power steering working? I don't feel like spending another dime on this car.

I searched everywhere on the net looking for articles about this issue and what else there is to do other than all the things I did! I can't find anything so I decided to come here to the experts and see what you guys say about this.
I had this car real nice before, I had 20's on it, a sweet air suspension, it all turned to junk and now it's my worthless work truck. Next month I am purchasing a 66 Mustang hard top from a friend and fully restoring that, no more with the Intrepid...work truck! But, I wanted to get this power steering going again and thats it. Maybe someone can help, hopefully! I would greatly appreciate it. Any ideas or suggestion would be killer! Because I don't feel like spending $250 for another rack n pinion. I put a lot of money in this car just to keep it going, and I mean a lot! haha.

Hope I didn't come off too harsh on the Intrepid to you guys, I love them to death and I absolutely love all you Trep Heads what you do with yours cars, I seen the pictures, but this one is a dud guys! lmao.
Any help would be appreciated like I said, if you don't want to reply here, my further contacts are:

Email: [email protected]
AIM: ChaosDeathkult

Cell: (818)523-4193 (Los Angeles, CA only pls)

Thanks a lot for your time guys! :icon_cool
 

·
Premium Member
Joined
·
16,743 Posts
Wow! Youv'e replaced the power steering pump (twice) and the rack. Short of some hoses being mis-connected (not likely at all), the only thing that comes to mind is that something in your steering is binding up - possibly as a result of the accident. It has to be that or, as you seem to suspect now, another bad rack. You can measure the pump pressure - that would tell you for sure if that's working.

Any hoses kinked or otherwise restricted (accident damage?)? Check lines going to cooler. The only other component in the whole system is the p.s. pressure switch, and all that does is send a signal to the PCM to bump the idle up to maintain p.s. pressure at idle - so that wouldn't cause your problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for responding.
I checked and even replaced some of the hoses.
Actually I found out I've been driving this whole time without the p.s. even being hooked up to its own cooler. It was goign straight to the rack and was flowing right back through the low side into resovoir... I just added the hoses going through the radiator yesterday, so NOW it has cooling too.

I never thought about a p.s. pressure switch, I know that is has pressure. I still get power steering, but only above 2500+RPM now.. when I don't really need it. I need it when trying to park or need to do a U turn or something...it really bums me out. I never had so much hatred towards a vehicle. I'm trying to think what else it could be that I am not doing or checking.. I read a whole web site about how Chrysler/Dodge makes shitty rack & pinions and how they eventually crack or pumps give out.. maybe I'm just **** out of luck and am stuck with no power steering for this car. I'm about to give up with this, I've put double the amount of money of what this car is actually worth into this car to fix this and fix that and get it running, maybe I should give up?

Anyway, I loosened both lines in the rack one at a time and made sure oil flows through both, they did bleed but I had to rev up to 2500 RPM to get the oil to flow out of the line onto the car/ground. So I know there's oil flowing to both lines great. I mean I had power steering after I empty the whole system and refill it. I have power steering out of my driveway and to the end of my street, after that it dies again and only get it at 2500+ RPM.

Weird case I have here isn't it? I'm lost myself and I've repaired tons of p.s. systems on many cars. Even other Chryslers..
 

·
Premium Member
Joined
·
16,743 Posts
ChaosDeathkult said:
...I've put double the amount of money of what this car is actually worth into this car to fix this and fix that and get it running, maybe I should give up?...
NO!! You can't do that now - got too much invested in it!! Heh heh! The age old dilemma. You're right - it is weird.
 

·
Registered
Joined
·
931 Posts
sounds similar to when the torsion bar inside the rack is on its way out. the thing that sucks is that you need a whole new rack since nobody rebuilds them. search ebay i just bought a rack for my intrepid 2 months ago $75 brand new.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
So you guys think it's the rack? I just got that replacement 4 months ago from a junkyard from the same model Intrepid. I don't really feel like spending $200 more on this car for a yard Rack n Pin and I also don't feel like buying a brand new one running the risk of it not fixing the problem. I think I will just drive it with no power steering until that thing dies.. we'll see what happens I guess. If I found out for sure it's the rack..I'll go with a yard Rack possibly.

-Eric
 

·
Registered
Joined
·
931 Posts
well to be honest since the rack is a common failure on our cars i wouldnt bother investing in a junk yard one in the first place. I see what your saying about not being sure if its the rack. do this as a quick (not accurate test). turn the wheel back and forth and feel how it is (should be rough according to what you've said). now undo your tie rods from the struts so that nothing is connected to that rack besides your steering column and the power steering pump+lines. start the car again and turn the wheel, it should be a bit more easy but you can still tell if the pump is doing its job, if it feels rough then you can concentrate on the rack. just a thought tho
 
1 - 7 of 7 Posts
Top