DodgeIntrepid.Net Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi my passenger seat motor seems it has died. So I went to take the seat out today and ran into a problem getting the clip off that plugs the main power to the seat. Do you need a screwdriver? I see that it can slide off almost like to unlock it but still can't pull the wires free. Any ideas? Thanks.
 

·
Registered
Joined
·
2,461 Posts
Changed mine a bunch of times after you get the yellow clip slide a small screwdriver in and pull back slightly freeing up the"clip lock."

Have patiance grasshopper!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Great thanks! I just took out the whole seat for now. Any idea what the prices are from Chrysler is for the seat motors or am I better off pull a seat out at a wrecker and taking the motor off.
 

·
Registered
Joined
·
2,461 Posts
If you end up going the junk yard route let me know what you ended up paying for a motor i'm thinking about using one for an air grabber hood!

200 posts wahooo!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Had a very hard time finding one in a yard here. So I found a shop to look at it and it wasn't the motor (was charged 40 bucks for it too!) I was told it was the cables going in and out of the motor. I install it again and didn't work now it seems to work but now the one that goes forward doesn't work. So I found a junk yard with a seat but asking 100 for the compete setup underneath. Anyone else have this problem. I was told the cables have worn down and need to be replaced. I know the motor works cause when I take one set of cables out one side works but both together won't work.
 

·
Registered
Joined
·
202 Posts
So replace those cables that run from the motor to the black plastic piece that the threaded metal rod runs through,worse comes to worse another member and myself need to get to a local yard soon for some power seat parts also,we could grab those cables while were at it instead of throwing them on the ground :) we have to take a pair of those off to get the parts he needs.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Hey thanks. Found a seat here. Now I've mixed the cables around and each side works on the right hand side. Together no go so I don't know if this is a gound issue that I'm not getting enough power to work them all. I think I'll get this undercarriage of the seat here for 100 bucks and hope that fixes the problem. Any other ideas what it could be? The cables look fine and motors work on there own but not together.
 
1 - 7 of 7 Posts
Top