DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
503 Posts
Discussion Starter #1
somewhat misleading. my WP and TB were replaced 2yrs ago. maybe 25k miles. 6 months later the WP starting leaking so i replaced it again. than several months ago it started leaking again so i decided to replace it today. its got a lifetime warranty and the store asked if i wanted to replace the TB since its under warranty also. hmm, probably should have but getting the belt out is a pain with the balancer in the way. so i was putting on the tensioner and 1 of the bolts snapped off. whoa. not good. luckily there was about 2 threads worth of bolt sticking out and i cut a slit in it with my dremel and was able to unscrew it. i replaced both bolts to be safe. than i got a lot of foam when i bled the thermostat. usually thats not a problem. 3.5L for info.
 

·
Registered
Joined
·
1,522 Posts
Is it possible since you keep getting the coolant leak, that your O rings behind the timimg belt/ water pump cover may be bad?

There are 3 O rings behind that cover that go into the cooling jacket.
 

·
Registered
Joined
·
503 Posts
Discussion Starter #3 (Edited)
i get a nice stain on the bottom of the pump from coolant leaking thru the bearing/seal. the last pump had a pretty good build up. its on the outside of the pump flange. of course the backside of the pump is exposed to coolant. thats where the pump impeller is. the stain looks like it is coming from the hub itself.
 
1 - 4 of 4 Posts
Top