DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
A while back I was getting a 0303 code. Changed all the plugs which seemed to solve it for a bit. Then the CEL came back on and the code reappeared. I swapped coil packs between the 3rd and 5th cylinder and got same 0303 code. At the advice of a fellow member I reset the computer. The CEL is now gone and so is the code. In fact I get the the P1684 code and the "DONE" however the car still shakes at low idle and the oil light comes on. Under accelleration the car if fine, and the oil level is good. Any suggestions?

Max
 

·
Registered
Joined
·
1,992 Posts
The IAC in the intake can get crudded up. I haven't had the problem, but others have.
Check the 'how-to' section on particulars to clean it...
 

·
Registered
Joined
·
1,992 Posts
Idle Air Control- a sensor-looking device with a plug and wires on the passenger side
of the air intake...here's another related post;


It may just be me but everytime I clean a throttle body I remove it from the car, remove the tps and iac. The iac is a controler that increase idle on start up and is located next to the tps. Then I clean the throttle body with throttle body cleaner and also clean the area the iac sits in. Then I spray a little cleaner on a rag and gently clean the carbon off the end of the iac. Make sure to be gentle and don't twist the plunger part just pipe it until it is clean. Reassemble everything and you should be good to go.
The Factory shop Manual can be found in the how-to section. Big file, good info!
 
1 - 4 of 4 Posts
Top