DodgeIntrepid.Net Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,806 Posts
Discussion Starter #1
Please lets have a moment of silence :crying: :violin:

Well the engine in my car decided to take a **** today. Was coming back from picking up my pay check pulled out on the highway and she ran like never before then about 3500-4000 rpm she slowly started getting tired and then boosh smoke just rolled into the interior of my car so i shifted it into neutral and she died, i pulled the plugs and every one of them had oil dripping off of them... My guess is the rings... I guess it is time for a rebuild seeing as how i still owe a little under two grand on the car.... :banghead::banghead:

On the good side of things the engine will be getting high compression, port and polished heads and intake, and of corse a nice bath so when she goes back in i can go ooohhh ahhh! :biggrin:

dat dat be all folks!

I'll have pictures of my pretty intake up here soon, and keep your ears and eyes open for my 3.5L rebuild!

Clayton!
 

·
Registered
Joined
·
2,079 Posts
I know the feeling.... I had my R/T take a crap on me in March... less than 2 months after I bought it...
Had the engine replaced 1 week after....

Anyways, good luck with the rebuild.
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #3
Where are some good places to get a rebuild kit from? I'm prob gonna use rpmmachine.com they look like a good company, but their slightly expensive $650...

clayton
 

·
Registered
Joined
·
780 Posts
weren't you in another thread trying to decide which 2nd gen to get....sounds like nows the time buddy. sorry bought your busted motor
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #8
I might be jumping the gun just a tad bit early on declaring that the engine popped. I've had two people tell me that it could be that the PVC system was clogged and blowing oil out the valve cover (last night) and i put the intake back on to keep it off the exhaust which could have sucked the oil threw the intake system and flooded the pistons with oil. It wouldn't blow much oil out at all at low rpm but once i hit higher rpms it would blow a lot of oil out, and this is what happened i got in the higher rpms and it started to just go blah!

clayton
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #10
I really hope so, we'll see what tomorrow brings. I looked and there is good sized oil puddles standing in the throttle bodys and what not...

Clayton
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #11
Well I pulled the plenum off changed the PVC valve, and cleaned all the gunk out of every where else. I put it all back together with new gaskets and hooked it all up with new vacuum lines and went to start it.................. Well it didn't start just set there and cranked and cranked It has compression i stuffed a paper towel down in the spark plug tubes and it blew it out of there with ease, the spark plugs aren't covered in oil only gas now... I'm stuck once again, only thing i can think of is that maybe my plugs are bad after soaking in oil for two days strait...

Clayton
 

·
Registered
Joined
·
3,934 Posts
Shouldn't really affect the plugs too much, but you could clean them good with varsol, then dry with a propane torch (don't go nuts, just dry and burn off any residue).
Also try disconnecting the battery for a few minutes if you already haven,t, in case the ECM needs to be reset, if is shut down due to the engine "failure"
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #13
I had the battery unhooked for all last night had half the day yesterday, i hooked it back up to get to my tools before i took of the plenum and i left it hooked up when i pulled it.. The car just acts like it has no fire... It has smoke coming from some where i'm not sure where exactly I'm thinking the exhaust...

clayton
 
1 - 13 of 13 Posts
Top