DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
455 Posts
Discussion Starter #1
My car is slowly leaking oil...i checked under my car today and my filter and all was cover in thick grease..... What causes the oil leak what and what do i need to stop the oil leak..... The leak is very very (loosing like an "eyedrop" of oil every day) slow but i want to fix it now before it gets any worst....what parts would i need to stop the leak..help anyone.
 

·
Registered
Joined
·
430 Posts
My car is slowly leaking oil...i checked under my car today and my filter and all was cover in thick grease..... What causes the oil leak what and what do i need to stop the oil leak..... The leak is very very (loosing like an "eyedrop" of oil every day) slow but i want to fix it now before it gets any worst....what parts would i need to stop the leak..help anyone.
grease or oil? did it look like is was anywhere above the oil pan (on the block sides)?

mine has an oil leak and it's the oil pan gasket itself... if there is nothing above the oil pan that has oil on it, then just replace you oil pan gasket. the pan can be removed and resealed without removing the engine from the car. check the Chilton's Manual 20361 for directions, or maybe someone has done a how-to on it...

if oil is on the sides of the block, then it may not be your oil pan and you need to find the source to fix it...
 

·
Registered
Joined
·
95 Posts
May sound like a stupid question but did you make sure your filter is on tight? There is also the possibility that the gasket from your last filter got stuck to the oil pan/filter adapter and is now sandwiched between the pan and your new filter. Take the filter off and make sure there is only one rubber gasket on it, and make sure there is not one stuck to the oil pan/filter adapter.
 

·
Registered
Joined
·
455 Posts
Discussion Starter #4
Yea....i had it to the dealership and they changed my oil and filter the last time....when i changed my oil and filter myself (which was threee times since i got my trep), the filter had no grease covering it at all so am thinking that the dealership didnt screw the filter on tight enough.
 
1 - 4 of 4 Posts
Top