DodgeIntrepid.Net Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 99 Intrepid with 2.7L. Just got it rebuilt. I ran the car for a half hour one day with no problem, the next time I ran it, it smelled like it was running hot. The temp gauge was fine (just below halfway). The T-stat was new but I changed it again and water pump was replaced, air was bled from system. It smells hot (like hot anti-freeze) on the drivers side of car. also sounds hot (crackling sound mainly from heat shields). I can't see anti-freeze leaking on the ground.

has anyone had the same problem?? Any clues??

Thanks in advance
 

·
Registered
Joined
·
165 Posts
check the bleeder on the front of your engine...you may see it leaking out of the plastic...then burning off..which is why you dont see any antifreeze under the car...there are some pictures of it around here..if no one sends them i will find them tonight when im not at school...good luck
 

·
Registered
Joined
·
4,388 Posts
stevedak said:
I have a 99 Intrepid with 2.7L. Just got it rebuilt. I ran the car for a half hour one day with no problem, the next time I ran it, it smelled like it was running hot. The temp gauge was fine (just below halfway). The T-stat was new but I changed it again and water pump was replaced, air was bled from system. It smells hot (like hot anti-freeze) on the drivers side of car. also sounds hot (crackling sound mainly from heat shields). I can't see anti-freeze leaking on the ground.

has anyone had the same problem?? Any clues??

Thanks in advance
Temp gauge just below half sounds normal. Smelling antifreeze from the driver's side is because the overflow (expansion) tank is over on that side. It could be just venting (normal) or the cap isn't on all the way. Double check that cap when its cold. Crackling from the heat shields is normal, just the metal expanding and contracting from the heat. Since you had those items in your cooling system replaced, keep an eye on your antifreeze level for a few days. You may need to add some later, if there was any air left in the system, sometimes it purges thru the vent in the radiator cap.
 

·
Banned
Joined
·
4,553 Posts
It may just be residual fluids from the motor rebuild/install. Check the stuff mentioned above, but if nothing is leaking, I'd venture to say that it's probably just residual fluids and the "hot smell" will go away with a few days of driving.
 
1 - 5 of 5 Posts
Top