DodgeIntrepid.Net Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
I've noticed a fuel odor after driving my Intrepid... any suggestions? :eek: :eek:
 

·
Registered
Joined
·
560 Posts
did you have the factory recall performed on the fuel rail? there was a recall a while ago...leaky 0-rings, fire hazard...go get it checked now if you havent...if you got the car used and dont know, pop the hood, and look for a "The FOllowing modificatinos have been made:" label, should be right under the dodge emblem...there should be two lines of codes...either way, go to a dealer.
OR
you could be having the same prob im having right now, which is a genuine fuel leak at the tank...my filler hose is leaking a bit, but wont leak when the tank is under 1/2 full...
 

·
Registered
Joined
·
2,427 Posts
valhalla...where's that sticker supposed to be? i have no idea what emblem you're talking about. do you mean under where the ram head logo is on the exterior of the car? if so i know for a fact there's no sticker there but my car DID have the recall performed....please reply.
 

·
Registered
Joined
·
560 Posts
i had a label inside of the hood, right where the release lever is...should be so you just pop open the hood and there it is...i'll email a pic of it to randy and ask if he'll post it somewheres...
 

·
Banned
Joined
·
439 Posts
another problem could be your oxygen sensors. last week my car basically died on me and when it would run, the smell of gas was so bad that my eyes would burn :rolleyes: got it fixed at pepboys though, they said it was both of my o2 sensors. got the car back tonight and it runs great without the smell. also, are you getting bad gas mileage??
 

·
Registered
Joined
·
2,427 Posts
O2 sensor failure is code 21** on the MIL fault code. wish randy would put the page up...
 

·
Registered
Joined
·
366 Posts
i have that same problem - gas smeel when i shut it off, i got the gas rail recall done about a weeek ago also so i dont know but it makes my garage smell bad
 

·
Registered
Joined
·
183 Posts
Discussion Starter #8
Originally posted by gary680:
another problem could be your oxygen sensors. last week my car basically died on me and when it would run, the smell of gas was so bad that my eyes would burn :rolleyes: got it fixed at pepboys though, they said it was both of my o2 sensors. got the car back tonight and it runs great without the smell. also, are you getting bad gas mileage??
My gas mileage is still pretty good... My check engine light has not come on either
:confused: If my O2 sensor(s) were malfunctioning, wouldn't that cause my check engine light to illuminate??? I have not had the recall done but I did purchase the car used. I'll have the dealer check that...

[ December 06, 2001: Message edited by: trutrep ]
 

·
Registered
Joined
·
560 Posts
did you check the check engine light check light? maybe the light burned out! :p
 

·
Registered
Joined
·
183 Posts
Discussion Starter #11
Originally posted by Valhalla 21340:
did you check the check engine light check light? maybe the light burned out! :p
Ha Ha. My check engine light comes on briefly when I start the car. :p Has anyone changed the O2 sensors themselves? I've seen a tool for it but I wonder how difficult it would actually be... :confused:
 

·
Registered
Joined
·
560 Posts
depends if theyre all rusted in place or not...and there are 4 of em, i believe...two on the manifold before cats, two after. and i believe also that its an expensive part either way...thats the only reason i havent gotten to mine, very little $$$ right now...(just bought another guitar, set me back a good amount, but it was worth it!!!!)
 

·
Registered
Joined
·
183 Posts
Discussion Starter #13
Originally posted by Valhalla 21340:
depends if theyre all rusted in place or not...and there are 4 of em, i believe...two on the manifold before cats, two after. and i believe also that its an expensive part either way...thats the only reason i havent gotten to mine, very little $$$ right now...(just bought another guitar, set me back a good amount, but it was worth it!!!!)
Yeah, the parts aren't cheap - Autozone pricing before CAT $34.99 after CAT $64.99 - I definantly don't want to pay for labor if I can help it!

:( :mad: :eek:
 

·
Registered
Joined
·
209 Posts
They come out a lot easier if the exhaust is hot. Of course you then run the risk of burning yourself. Also if the sensor tool doesn't get a good grip, you can cut the wires off and use a standard socket.

I would verify that this is your problem before buying 4 sensors though.
 

·
Registered
Joined
·
16 Posts
I found the smell went away after using Run-Rite, which cleans all the crap out of the motor and exhaust system. Performance was significantly improved after the treatment.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #16
Originally posted by Dr. Mogie:
I found the smell went away after using Run-Rite, which cleans all the crap out of the motor and exhaust system. Performance was significantly improved after the treatment.
Is that something I can just pick up at the auto parts store? Is is a gas additive or does it go in the engine? Thanks.

:confused:
 
1 - 16 of 16 Posts
Top