DodgeIntrepid.Net Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
I was just wondering if anyone has ever had any transmission problems w/ their cars. I thought mine was big time broken last week. I was driving and the car would not shift out of second gear.... then the check engine light went on. :eek: I found out later that the car put itself in to a fail safe mode. Luckily the only problem with the trans was that it had 3 leaks and the speed sensor needed to be replaced. Now I know Dodge/Chrysler is not known for their transmissions but my car only has 46K on it and is well taken care of. (besides the occasional racing). It seems kinda early for these kinda of problems. Just wondering if others have had similer problems with lower/higher miles.

A friend of mine who used to work for dodge said that of all cars being Dodge/Chrysler etc.....Intrepids have the best transmissions of them all. Don't know what that says for the those others :confused: :confused:
 

·
Registered
Joined
·
638 Posts
Transmission problems? These cars? Nah.... :p Seriously, that's a big problem. Do a search for these issues and you'll get bombarded with results. The thing with these trannys are that they are very unpredictable. Some fail right off the bat while others have gone 200K miles without a problem.

The best thing you can do is get your transmission serviced (flushed, filter change, and refilled with GENUINE Mopar ATF+4) on a regular basis. Since you have 46K miles you should have had it done at least once. I drive in heavy traffic daily so I get it done once a year or about every 15-20K miles. Some of the guys here have installed transmission coolers which is supposed to help a lot since heat is the tranny's biggest enemy.

Do a search and you'll find all the info you need. :)
 

·
Registered
Joined
·
11,960 Posts
My transmission ate a sensor at about 15000 miles :p ... car went into limp mode, omg, it was stalling and not driving well at all. Took the dealer 3 days to fix it (and I got a nice Ram 4x4 rental because of it :))
 

·
Registered
Joined
·
638 Posts
Originally posted by TrepidHelp
i lately have been having trsnny problems..... seems that when i put in reverse ( little more clunk/noise then usual. when press gas in reverse i will hear a bang. not sure exactly what it is ??
That doesn't sound good. The last time my car did that it meant a transmission replacement. Have you flushed the fluid lately? Some times that can work wonders. At the same time, depending on who you take it to, they will do an inspection of hte internals and let you know if there is any damage.
 

·
Registered
Joined
·
181 Posts
your problem is a sensor problem.. not the tranny... goto the dealer and they will fix it for a couple hundred .......its a common problem :crazy:
 
1 - 7 of 7 Posts
Top