DodgeIntrepid.Net Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
my 93's tranny is all messed up, like when the engine is cold as ice it drives and shifts fine but once it gets warmed up it always shifts into overdrive, i've counted the gears, theres 5. it shifts fine 1, 2, 3, and 4, but when it goes into that last gear it slips like madd so i have to let off and slowely ease back on the gas so it goes in. like, once it's in gear it works fine at higher speeds, above 45mph. but even if i go 20mph it shifts into 5th, then jumps back into 3rd, 4th, and back into 5th. it does this all the time none stop, so im forced to drive in L3 or stomp the gas and let off every 100 feet. any body have any suggestions, i bought some lucust tranny fluid additive and it helped it shift smoother into 3rd and 4th but it did nothing for that last gear

if i got an auto stick would that solve this problem or make it worse. i really want to get and A/S set up so would it damage it or help it

thanx
 

·
Registered
Joined
·
2,676 Posts
The 42LE which is what you have is a 4 speed. It sounds like you have a worn out input shaft seal, pretty common but it requires removing the transmission from the engine to fix it. If you are mechanically adept, there is a shift kit / rebuild kit that has superior replacement seals from transgo, part #K72908J and available from www.northernautoparts.com for $19. You'll have to replace the pan gasket and while your in there clean the input/output speed sensors...I just got my shift kit here and its a very complicated procedure to install the entire kit.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top