DodgeIntrepid.Net Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
my left turn signal is not working it's just solid when I try to use it and it's makes this buzzing noise when I try to turn them on.
 

·
Premium Member
Joined
·
16,613 Posts
Bad relay? located under the dash up by the brake pedal IIRC.
Yep - flasher is mounted on a panel that contains several connectors, and hangs down to the left of the brake pedal. It's the black thing on the lowest left slot in that panel.
 

·
Premium Member
Joined
·
16,613 Posts
From an earlier post:

Below is a photo that I took of what RoR2 described. I've never had to remove mine, but people say that it is difficult to remove it, but there is a latch you can release with a screwdriver to get it out without much trouble [a slot that you stick the screwdriver blade into to press the release latch]. Before that became well known here, people would just abandon the old flasher in place, plug the connector into the new one, and zip tie it to a wire harness or air duct. Either way will work.

I believe that there are certain aftermarket brands and part numbers of supposedly the right type (5 pinners) that don't work correctly in our cars (they blow a fuse when the hazards are used) - perhaps someone who knows the details on that can post that info. Otherwise you can go with the OEM part.

The only black connector-looking thing in the photo is the flasher (for reference, the white thing to the right is the brake switch with it's plunger aimed at a little bracket on the brake pedal arm - pedal is below the bottom of the photo, and you can see the steering column shaft with u-joint further to the right, near top of photo is the air duct, and at very top of photo is the DLC connector):

 
1 - 7 of 7 Posts
Top