DodgeIntrepid.Net Forums banner

21 - 40 of 60 Posts

·
Registered
Joined
·
2,258 Posts
So, any more thoughts on that badly needed body work/paint job?

Amazing how well that car runs, given the amount of idle time you said it had in its life.
 

·
Registered
Joined
·
672 Posts
Vee,
Would you mind asking a few questions?
First, can I ask where you got your spoiler? I read that it is a 300m special spoiler, but how woud I go about getting one.
Second, What size tires are you running on the 300m special rims and also can I steal the idea to use the rims and spoiler from a 300m special from you? I would be sending the spoiler to a body-tech friend of mine and having him extend it a bit to "look like" the wings would be past the actaul body lines of the rear fenders.
Thanks,
-Smurf-
 

·
Dain bramaged
Joined
·
7,202 Posts
Discussion Starter #27
Are the wheels different on the special as opposed to that of just a regular 300m? Thanks Veeborg
only the Special got the 18inch wheels *and some of them didn't even get them*. Other then the size everything else is the same. *lugpattern/backspacing/etc*

you have to run 245/45 series tires, any taller of a tire and you'll rub the spring perch on the strut.
 

·
Registered
Joined
·
3,850 Posts
what kit? he bent that all freehand and by eyeball.
The kit that he is going to make and ship to me so that I can put it on my car! DUH

...nevermind, I'll just drive up there with no exhaust and have him whip something up from scratch.
 

·
Registered
Joined
·
534 Posts
I know I've asked this before, (I just can't remember where) But what all needs to be done to put a bigger alternator on the 3.3l?


I know you can use one from a ram or durango, but doesn't it need like a different pulley and wires spliced?
 

·
Dain bramaged
Joined
·
7,202 Posts
Discussion Starter #40 (Edited)
Ok, Story Time. Buddy borrowed my car for a while. Returned it to me mentioning there had been a few issues but he had "fixed" them. Cue me driving around and the car cutting out. Open the hood and finding several wires on the harness had melted together, and then finding 50-60 amp fuses in 20amp holes. So the car sat. Every time I looked at it I just got angry.

I finally had enough. I got under the hood and started tracing wires, pulling the melted ones apart. I dropped a battery in it and turned the key.


It was much noisier on the very first start, most of it being the lifters had collapsed from the long time sitting. It has a miss, which is related to the ticking noise. I'm gonna change the oil/plugs/wires and run some marvel mystery oil through it. If the noise/miss is still there after that, I'm gonna check the injectors and pull the valve covers off. It definitely could use fresh gas, whats in the tank is old.

End of the day, It runs again. It went right into gear when I shifted it. It needs a lot of cleaning and elbow grease, but I've got my car back.
 
21 - 40 of 60 Posts
Top