DodgeIntrepid.Net Forums banner

1 - 20 of 99 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
You know how they talk about American cars being weak and stuff. I was wondering what kind of problems you guys have encountered on your Intrepids. Things like mechanical, electrial, etc. Mine hasn't given me any...yet. So, how about you guys?
 

·
Registered
Joined
·
4,739 Posts
My car wouldnt start four weeks after taking delivery which got me stranded in a parking lot. Dealer said it was probably a building defect... broken wire to the starter.

All is well since. I have a 7yr/75k Chrysler service contract regardless so im good to go.
 

·
Registered
Joined
·
18 Posts
Mine needed a new drivers side airbag harness replaced. Other than that, no other problems on my 2001 R/T with over 10,000 miles.

Dane
 

·
Registered
Joined
·
1,610 Posts
Originally posted by Intrepidatious:
Input Speed Sensor on the trans. That's pretty much it after almost 3 years. Very reliable car.
I have to say the exact same thing.
 

·
Registered
Joined
·
1,269 Posts
Have only had my car ('98 ES) since last August, have put 11k on it, has 72k and the only thing I've had to replace is the drivers door window motor. Other than that, no lights have come on and nothing has fallen off yet, knock on wood ;)

Although I think the drivers front strut is going bad, or a CJ joint, something in the front end of the suspension, as my car gets noticable shakes at highway speeds, but overall, the car has been fantastic. :D
 

·
Registered
Joined
·
11,960 Posts
Wow, some of you guys put up with a lot and still think that your car kicks ass??? I think people who buy Jap crap put up with a lot less before they get pissed off. I dunno, is it loyalty to Chrysler perhaps??? In my case I think that I'm very loyal and would've probably bought anything, just as long as the money went to Chrysler!

Anyway, my temperature control fan sortof makes a clicking/grinding noise when it gets cold (the colder the louder) and when in fourth gear accelerating on the highway, my car kinda is rough (the gas petal kinda shakes a bit) thats about it. The molding in the drivers side rear wheel well is different than in the passenger side rear wheel well. Either it came like that or there's something wrong with the drivers side??? Oh, there was also a scratch inside the rear drivers side door (just touched it up), probably been there from the factory, you can't see it unless the door is open, it's near the latch on the car (not the door). Also I just got my first nick, prob hit by a stone. A small piece of paint missing from the hood :(

[ January 06, 2002: Message edited by: Avenger ]
 

·
Registered
Joined
·
11,960 Posts
Oh and by the way,
I AM VERY HAPPY WITH MY R/T!!!
 

·
Registered
Joined
·
5 Posts
Only thing going wrong with my 2000 RT is the driver side window motor is starting to make noise. Everything else is great.
 

·
Registered
Joined
·
217 Posts
My list:

All 4 door seal replaced due to shrinkage.
engine tear down twice to replace faulty valves.
drivers front wheel bearings shot, repacked.
2 different window motors replaced.
Some type of oil leaking from engine can't remember what it was now.
squeek in the dash

All the above fixed under warranty

The window trim is starting to shrink again
their is a rattle in the dash now
starting to bump shift first and second gear.

Those are things I've got the dealer looking at now.

just turned 18,000 miles on my 2000 se
 

·
Registered
Joined
·
121 Posts
Discussion Starter #12
That sounds like a lot of problems. I'm happy with mine, i put too much miles on it, i have over 35,000 miles on it, and i haven't enocountered a single probles, but i can see that i'm not far from getting something bad :(
Hope, not, but oh well.
Thanx for your replies guys :cool:
 

·
Registered
Joined
·
1,226 Posts
leaky windshield upon delivery. dealer replaced all the carpeting.

and engine light came on @ about 5000 miles....loose gascap.
 

·
Registered
Joined
·
15 Posts
I had a loose engine oil cooler tube that leaked a little oil at 5000 km and a noisy muffler at 19000 km. I am still VERY happy with my car compared to my old Mercury Sable. :)
 

·
Registered
Joined
·
138 Posts
Just got the car back from the shop. Seems they have attributed an exhaust rattle I was complaining about to the catalytic converter. The part is now on order.

The only other problem I've had is a loss of freon last summer. I really attribited that to too many high RPMs jaunts while the A/C was on (I must learn to shut it off when playing).
 

·
Registered
Joined
·
2,576 Posts
Climate control malfunction. Front engine cover oil leak. Oil pan leak. Power steering pump leak. 38k miles and still climing. Love my car! DODGE for LIFE!
 

·
Registered
Joined
·
16 Posts
One major problem. Tranny replaced about one month after purchase. Car "neutralized" a couple of times when cold and first put into gear. Was taking it to dealer to get a paint scratch fixed. Mentioned it to them then.

They actually duplicated the problem - diagnosed the transmission pump. Replaced, diagnosed the same problem when time to road test. Dealer called Chrysler. Chrysler told them to put in a new transmission. Shipped a factory fresh tranny down, had the car three days later. Tech said the tranny case had a bad casting, cost Chrysler about $2,500 for that little snafu.

That and the cold engine low rpm growl TSB, that has been it.

So far, so good with 18,000 miles on it. Have a warranty out to 100,000 miles.
 

·
Registered
Joined
·
471 Posts
98ES 85K miles

Steering wheel was crooked

Windshield was warped, finally started to split at least 15% of the way across. Dealer tried to tell me it was a rock yes the split started under the side plastic windshield cover. Must have been one bad ass rock. :) Second windshield is slightly warped but hasn't split.

Rear door panel started to fall off, both panels were replaced.

The rear passenger overhead door handle was missing on of the bolt threads, rattles like hell.

Plastic piece missing on the seatbelt assembly on the passenger side.

Raidiator split. Oh that was a cheap fix, sheya right.

Brake light bulb on the trunk went out.

Dead cell in the battery caused the lights to dim when going uphills or when having a load on the engine.

Serpentine Belt replaced.

Dash rattles, getting worse

Tranny would drop into netural, sucked going up hills, PCM updates helped.

One of the struts is leaking, more or less their all asta. :)

Shall I keep typing, HEHEHE realize also this was probably one of the first Intrepids built as well since I got in in Dec of 97.

Still runs fast as hell, V8 Mustangs don't do so well over a 100. Ok that NSX spanked me fine I'll admit that.
 

·
Registered
Joined
·
112 Posts
The only thing I've had to do is to replace the right rear wheel bearing at 35,000. I also noticed my rear door seal looks like it shrunk cause theres a small gap and you can hear air coming in at highway speeds. I could also kick myself in the ass for not taking my polished aluminum rims off sooner now that winter is here cause I took my car to one of those touchless car washes and they're chemicals stained my rims. Had to use Mothers polish and do all 4 rims. So to anyone else out there...beware!
 

·
Registered
Joined
·
121 Posts
Discussion Starter #20
Sorry to hear all that man, that was a lot of pain you went through. I really hope your 02 works better and you be happier
 
1 - 20 of 99 Posts
Top