DodgeIntrepid.Net Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
I was wondering if theres somthing wrong or if I'm being paranoid. I was driving around today in 105degree weather and I have my air on and the temp goes way up like the line b4 the red. When I'm driving it will go between the middle and that line b4 the red. When I shut off the AC the temp will go down and it stays in the middle. The car has 88K on it and I know i'm due for a waterpump and timing belt. Am I being paranoid??
 

·
Woober Goobers!
Joined
·
51,840 Posts
I'd bet one of your electric radiator fans has taken a dive. That whole assembly with shroud and both fans can be had on ebay for around $130 shipped. A few hours work and you're back in business. Don't let it keep overheating.
 

·
Woober Goobers!
Joined
·
51,840 Posts
Both fans are dual speed..if one or both doesn't kick into high then that will lead to what you describe. The other thing is a clogged/obstructed radiator. Might look into a flush/fluid change. The point is the gauge indicators you describe indicate something bordering on overheating and is not normal. Getting to the line just before the red is not a good indication. If you stop the engine when it's at that point then you have no cooling at all and it gets even hotter! Turning off the A/C drops the load on the engine and drops the temp like you describe. Any way you look at it..get it checked out before something expensive happens.
 

·
Registered
Joined
·
692 Posts
as ronbo described - its not a good sign. I drive with AC full and my needle always stays below the half mark.

If you are positive that the fans are working, may be its time to do a radiator flush. I did mine @ 75K. Changed the t-stat and added some redline water wetter. No heating issues at all.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top