DodgeIntrepid.Net Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
565 Posts
Discussion Starter #1
One of my Xenon bulbs "10k" is starting to flicker and some times will not ignite unless i turn the light switch on and off a few times.. even after it lights its kinda dim. Question is do xenon bulbs just go out completely or do they die slowly? or Could it be my voltage ballast going? All components are still covered under warrenty, but just wanted to get a little input before i submit the problem.
 

·
Registered
Joined
·
753 Posts
My experience with zenon bulbs, is that they burn out at once. Mind you my experience is limited....only had a couple of sets..
 

·
Registered
Joined
·
1,158 Posts
I would have to say thats its either the bulb dieing or the ballast taking a dump on you. take the bulb thats not flickering and put it on the other side and see if its stilling flickering if so then you know that the bulb is shot. if the one not flickering starts to flicker then its the ballast
 

·
Woober Goobers!
Joined
·
50,149 Posts
Don't rule out corrosion or a bad connection at the bulb socket. Code2 has outlined a good method to pinpoint the cause. If the retaining pins on the bulb base for the connector socket are broken you may end up with the flicker. The other thing is if the ballast isn't getting full DC power then it will not ignite the bulb properly. Same thing there...check for a good connection at the 9006 connector going to the ballast. If you don't have a 9006 plug in connection make sure whatever method to connect is clean and free from corrosion..etc.
 
  • Like
Reactions: VegasTrep02

·
Registered
Joined
·
565 Posts
Discussion Starter #6
Well the bulb finally died, so i only have one headlight till tuesday when im off work in the daylight so i can take my lights apart and see WTF! Thanks for all the input guys.
 

·
Registered
Joined
·
141 Posts
I'm betting it was the ballast not giving the right voltage. i know it's a completely different scale, but the xenon bulbs at work flicker due to voltage fluctuations, and bulb life is shortened a lot by ballasts not giving then the juice they need. of course i could be wrong, you said you only have 1 headlamp now, so i assume you tried another lamp in there.
 

·
Registered
Joined
·
1,985 Posts
I had that problem, and it turned out that the bulb had broken retaining pins, and it would cut off once in a while, and after a while, it died completely, check the balast to bulb connector, since mine, every time it would flicker off, it would make the arc before the bulb, burning the crap outta the connector.
 

·
Registered
Joined
·
565 Posts
Discussion Starter #12
Well toasted bulb confirmed, new bulbs came in today and installed..Covered under warrenty they sent me 2 sets 10k's and 12k's as i requested free of charge!! i installed the 12k's today to get that nice barney look :) lol
www.Xenonpros.com
 
1 - 12 of 12 Posts
Top